Menu
SuiteCRM Pull Request Party hosted by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: Import records take a lot time

Import records take a lot time 1 month 4 days ago #75493

  • covalle@infranet.support
  • covalle@infranet.support's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Hi we having big issue to import .csv files, took 9 to 10 minutes 1000 records, we have 72G Ram 24 Cores 1Tb disk, Versión 7.10.11
Sugar Versión 6.5.25 (Compilación 344), PHP7.0.32, Maria DB, on php.ini we modified the upload memory at 30G, we fallowing every step from Developer Guide. no errors on log, or slow queries

Kindly help me to fix the issue
The administrator has disabled public write access.

Import records take a lot time 1 month 3 days ago #75517

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 8789
  • Thank you received: 1337
  • Karma: 323
If you want to do really heavy duty work, check out this post:

www.jsmackin.co.uk/suitecrm/large-imports-in-suitecrm/

But we can try to just fix some small detail. For example, what is your memory_limit in php.ini? Make it 512 MB.

You can also try this:

1. Increase your SuiteCRM log level to DEBUG in Admin / System settings

2. Open a separate shell into your server. Make sure it records a lot of scrollback (like 10000 lines)

3. Run "tail -f suitecrm.log"

4. Now run the import (just a few rows) and you will see A LOT of log messages scrolling by. Whenever you notice it stalling, with a visible delay, press "return" a few times in that shell window to leave some blank lines.

5. When it's over, copy-paste all those lines into Notepad++ or some editor, and examine what it was doing when it got delayed.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.
Time to create page: 0.117 seconds
Powered by Kunena Forum