Menu
SuiteCRM Pull Request Party hosted by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: KReporter not working

KReporter not working 1 year 4 months ago #60393

  • John - EZS
  • John - EZS's Avatar
  • Offline
  • SuiteCRM Is My Life
  • Posts: 336
  • Thank you received: 32
  • Karma: 7
Quote from jrivas posted here: suitecrm.com/suitecrm/forum/announcement...itecrm-7-10-released
Hello,

I see everything very well with the new version :) . But there is something important that we use with SUITECRM, which is KREPORT. Before it worked fine but in this version I can not make it work correctly. it installed the KREST Core 2.5.3 but it does not work.

Please someone help me.


Example webbrowser inspector error:

Failed to load resource: the server responded with a status of 500 (Internal Server Error)

KREST/KReporter/core/vizcolors?_dc=1519316641566&nodeid=&page=1&start=0&limit=25

KReporterDesigner.js:14 server-side failure with status code 500


Thank you very much.
The administrator has disabled public write access.

KReporter not working 1 year 4 months ago #60395

  • John - EZS
  • John - EZS's Avatar
  • Offline
  • SuiteCRM Is My Life
  • Posts: 336
  • Thank you received: 32
  • Karma: 7
I tried getting Kreporter running on my fresh SuiteCRM 7.10 installation on Mac OS: Having the same issues.

KReporter will show up but the Dropdown of available modules is empty.

I see in the KREST installation guide, that to test whether KREST is running correctly you can open the URL

[URL to your SuiteCRM installation]/KREST/sysinfo

In my case this doesn't work.

According to the installation guide this most likely is caused by the apache rewrite engine not working.
I tried setting up Apache the way the installation guide suggests (on my Mac), but so far no luck.
The administrator has disabled public write access.

KReporter not working 1 year 4 months ago #60398

  • John - EZS
  • John - EZS's Avatar
  • Offline
  • SuiteCRM Is My Life
  • Posts: 336
  • Thank you received: 32
  • Karma: 7
I changed line 19 in index.php (inside KREST folder) to display errors (on instead of off).

Then opened up [your suitecrm URL]/KREST/sysinfo

And get the error:
Fatal error: Call to undefined method Slim\Http\Headers::extract() in /Users/johnezs/Sites/SuiteCRM-7.10/KREST/Slim/Environment.php on line 161

The code on that line is:
$headers = \Slim\Http\Headers::extract($_SERVER);
The administrator has disabled public write access.

KReporter not working 1 year 4 months ago #60485

  • sieberta
  • sieberta's Avatar
  • Offline
  • Elite Member
  • For the good of the whole...
  • Posts: 303
  • Thank you received: 45
  • Karma: 11
I was a previous user of KReporter, and lost functionality a while back during an upgrade. When I went to check it out, I saw the developers were creating their own CRM: SpiceCRM and didn't seem to be focused on SuiteCRM compatibility anymore.

I've been happy with using the SuiteCRM Reporting tool that was added, in combination with a product called PHP Report Maker. The latter is generic (not CRM aware) but I love what I can do with it, including the graphs. I opted for the paid version. I have version 9, but will be upgrading to 10 when I upgrade to 7.10.X (lts).

I simply run the two side by side and pint PHP Report Maker to my SuiteCRM database. I preferred being able to write my own SQL anyhow. I know this solution won't be for everyone, but I love it.

http://www.hkvstore.com/phpreportmaker/

Sieberta
The administrator has disabled public write access.

KReporter not working 1 year 4 months ago #60783

  • John - EZS
  • John - EZS's Avatar
  • Offline
  • SuiteCRM Is My Life
  • Posts: 336
  • Thank you received: 32
  • Karma: 7
I got KReporter running without any problems in SuiteCRM 7.7.4 (running on Debian). But so far no luck getting KREST to work on my local Mac installation. Pretty sure it has nothing to do with SuiteCRM 7.10. I just can't get KREST (or more specifically the Slim PHP framework) to work on my system. And KReporter depends on KREST to work.

Here's my support thread with SpiceCRM. They don't officially support SuiteCRM. But as this doesn't seem to be a problem related to SuiteCRM, but something more general with KREST, I'm hoping they might help me solve the issue.

community.spicecrm.io/t/cant-get-kreporter-slim-to-work/256
Last Edit: 1 year 4 months ago by John - EZS.
The administrator has disabled public write access.
Time to create page: 0.036 seconds
Powered by Kunena Forum