Menu
Welcome, Guest
Username: Password: Remember me

TOPIC: /Api/access_token shows 404 "File not found"

/Api/access_token shows 404 "File not found" 3 weeks 5 days ago #90804

  • Endymion
  • Endymion's Avatar
  • Offline
  • New Member
  • Posts: 19
  • Thank you received: 1
  • Karma: 0
Hi all,

when I want to work with Api v8 I got a strange error: /Api/access_token gives me "File not found." (which is a custom message, because if I use /Api/abcdef it gives me Server Error 404 Page Not Found - which is the standard message)

When I use Api/index.php/access_token though, everything works normally.

Because of some previous problems with the cache I got an updated upgradeAccess.php and thus a different but working .htaccess:
I tested it by redirecting the Api/access_token bit to google.com and it works.

.htaccess
Warning: Spoiler! [ Click to expand ]


What else can I do in order to fix this?

Best
Sven

PS: Version 7.11.8, Debian 9, Plesk (nginx + apache)
PPS: I created the keys needed for v8 and I changed the Encryption key too.
Last Edit: 3 weeks 5 days ago by Endymion. Reason: PPS
The administrator has disabled public write access.

/Api/access_token shows 404 "File not found" 3 weeks 5 days ago #90816

  • Endymion
  • Endymion's Avatar
  • Offline
  • New Member
  • Posts: 19
  • Thank you received: 1
  • Karma: 0
After some more digging and googling it seems to be the same error as he has after the initial fix (upgradeAccess.php + .htaccess)
suitecrm.com/suitecrm/forum/installation...-forbidden-error-403

Errorlog gives me:
[proxy_fcgi:error] ... AH01071: Got error 'Primary script unknown'
The administrator has disabled public write access.

/Api/access_token shows 404 "File not found" 1 week 4 days ago #91425

  • rmunoz
  • rmunoz's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
Hi,

I'm having the same issue here '/suitecrmApi/access_token 404 "File not found"

Centos 7 (7.7.1908), php 7.3.11, SuiteCRM 7.10.21 LTS

Was this issue fixed?

Thanks
The administrator has disabled public write access.

/Api/access_token shows 404 "File not found" 1 week 4 days ago #91446

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 11371
  • Thank you received: 1687
  • Karma: 386
Try running a Admin / Repairs / Rebuild htaccess

Please tell me if it solves anything. Thanks

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

/Api/access_token shows 404 "File not found" 1 week 4 days ago #91450

  • Endymion
  • Endymion's Avatar
  • Offline
  • New Member
  • Posts: 19
  • Thank you received: 1
  • Karma: 0
It is not resolved yet.

I currently restrain from applying the filechanges (in 9 files) from the other thread, because I can not overlook what else might be affected.
I will just use the direct path to the api in the meantime and wait for an official patch.
The administrator has disabled public write access.

/Api/access_token shows 404 "File not found" 1 week 4 days ago #91451

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 11371
  • Thank you received: 1687
  • Karma: 386
Ok, but if we're waiting for an official patch we need to make sure there's an issue on GitHub for this, is there?

If there isn't, can I ask you to please open one with all the details? Thanks

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
Last Edit: 1 week 4 days ago by pgr.
The administrator has disabled public write access.

/Api/access_token shows 404 "File not found" 1 week 3 days ago #91515

  • Endymion
  • Endymion's Avatar
  • Offline
  • New Member
  • Posts: 19
  • Thank you received: 1
  • Karma: 0
You said in this thread
Yes, you should be ok to apply that to 7.11.

Whatever we put on the hotfix-7.10.x branch gets merged later into hotfix-7.11.x.

You will note that this patch is mostly adding stuff, as long as you put it in the right place you should be ok. Just remember to start by making back ups of the original files.

So I expected the fix to find its way into the master branch. Am I correct?

If so, I wait for this to be published and if the problem persists, I will open up an issue on GitHub.

pgr, are you involved in development? When is the next patch going to be published?
The administrator has disabled public write access.

/Api/access_token shows 404 "File not found" 1 week 2 days ago #91548

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 11371
  • Thank you received: 1687
  • Karma: 386
Oh, so this is the same issue as that other thread? The .htaccess fix solves this here?

Yes that should already be part of 7.11.9, but it's best to wait for 7.11.10.

It is coming out pretty soon - we're past the "code freeze", nothing new is going into it, but there is always an element of uncertainty here because it can only be released when it passes all the tests. We're currently improving the test system itself, and some testing processes, so some things are still a bit in an evolving state, which doesn't help with setting dates.

So: it's certainly possible that it is coming out on Monday, but I can't guarantee it.

You ask if I am involved in development - not directly, or only occasionally. I am a developer, so sometimes when the occasion is right I submit some patches myself: github.com/salesagility/SuiteCRM/pulls?u...3Apr+author%3Apgorod but that is not my main assignment.

But I follow everything that goes on in GitHub and I am in constant contact with the Product Team. You could say I cooperate in the link between the Product Team and the Community.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
Last Edit: 1 week 2 days ago by pgr.
The administrator has disabled public write access.

/Api/access_token shows 404 "File not found" 1 week 1 day ago #91594

  • Endymion
  • Endymion's Avatar
  • Offline
  • New Member
  • Posts: 19
  • Thank you received: 1
  • Karma: 0
Oh, so this is the same issue as that other thread? The .htaccess fix solves this here?

I don't know if it does resolve this issue. Instead of changing 9 files back and forth (and possibly make a mistake or missing other related changes) I decided to wait. I think I nailed the issue down to .htaccess, which means I can use the API without rewrite in the meantime.
You could say I cooperate in the link between the Product Team and the Community.

Thank you for your great job there. I am evaluating to shift to SuiteCRM with two customers who use cloud CRM right now. Apart from the well rounded and feature rich core SuiteCRM and great extensions it is your support heavily tipping the scale.
The administrator has disabled public write access.
The following user(s) said Thank You: pgr

/Api/access_token shows 404 "File not found" 5 days 22 hours ago #91714

  • Endymion
  • Endymion's Avatar
  • Offline
  • New Member
  • Posts: 19
  • Thank you received: 1
  • Karma: 0
Update:

I upgraded to 7.11.10 (which changes the .htaccess) but still the issue persists. I opened an issue on GitHub
The administrator has disabled public write access.
Time to create page: 0.182 seconds
Powered by Kunena Forum