Menu
SuiteCRM Pull Request Party hosted by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: How can you set the MySQL wait_timeout for an upgrade session

How can you set the MySQL wait_timeout for an upgrade session 2 months 1 week ago #77770

  • balandar
  • balandar's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
I am getting a General error: 2006 MySQL server has gone away when attempting to upgrade a SuiteCRM instance.

From what I've researched this has to do with the wait_timeout setting for MySQL. On my server it's set to 60. Unfortunately, as it's a shared business server on Godaddy, I can't change it globally.

However, it appears I may be able to set the session wait_timeout. E.G. SET session wait_timeout=600

What file/where would I set this for the upgrade, is that possible?

Thanks in advance!
The administrator has disabled public write access.

How can you set the MySQL wait_timeout for an upgrade session 2 months 3 days ago #77903

  • suitecrm_developer
  • suitecrm_developer's Avatar
  • Offline
  • Elite Member
  • Posts: 298
  • Thank you received: 32
  • Karma: 4
Hi,
Have you set the following settings in ini file??
Like

max_execuation_time = 10000
max_input_time= 10000
upload_max_filesize = 60M
max_execution_time = 200
post_max_size = 120M

Also check this URL

docs.suitecrm.com/admin/installation-guide/upgrading/

Thanks
Sohaib Majeed
SuiteCRM Developer
Upwork ==>> www.upwork.com/fl/sohaibmajeed?viewMode=1
Skype ==>> sohaib.majeed44
The administrator has disabled public write access.

How can you set the MySQL wait_timeout for an upgrade session 3 weeks 2 days ago #79652

  • balandar
  • balandar's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Just an update. Godaddy will not change the wait_timeout on shared servers. I ended up upgrading to a VPS.
The administrator has disabled public write access.
Time to create page: 0.046 seconds
Powered by Kunena Forum