Menu
SuiteCRM dedicated support by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: Cannot run install.php for initial installation

Cannot run install.php for initial installation 2 months 1 week ago #70403

  • wlstolzus
  • wlstolzus's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
I am just starting with SuiteCRM.

I installed apache on Ubuntu, and got the default apache page.
I created a directory and copied the installation files for SuiteCRM in my apache root directory.

I ran these commands:
sudo chown -R www-data:www-data .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload
sudo chmod 775 config_override.php 2>/dev/null

The first thing I noticed was that the config_override.php file DOES NOT EXIST. Maybe that is why the error message is directed to null.

So, I then opened my web browser to the <site>/install.php page.
I did NOT get the install button. Instead I see a bunch of text on the screen like this:

'; $msg .= 'Although the minimum PHP version required is '; $msg .= constant('SUITECRM_PHP_MIN_VERSION').', '; $msg .= 'is not recommended due to the large number of fixed bugs, including security fixes, '; $msg .= 'released in the more modern versions.
'; $msg .= 'You are using PHP version '. constant('PHP_VERSION').', which is EOL: php.net/eol.php.
'; $msg .= 'Please consider upgrading your PHP version. Instructions on php.net/migration70. '; die($msg); } $session_id = session_id(); if(empty($session_id)){ @session_start(); } $GLOBALS = true; define('SUGARCRM_IS_INSTALLING', $GLOBALS);
...
...

There is a LOT more of that. The page goes into an endless reload loop that I have to kill.
In my web log directory, I see nothing in error.log, but lots in access.log. That one looks like this:

'; $msg .= 'Although the minimum PHP version required is '; $msg .= constant('SUITECRM_PHP_MIN_VERSION').', '; $msg .= 'is not recommended due to the large number of fixed bugs, including security fixes, '; $msg .= 'released in the more modern versions.
'; $msg .= 'You are using PHP version '. constant('PHP_VERSION').', which is EOL: php.net/eol.php.
'; $msg .= 'Please consider upgrading your PHP version. Instructions on php.net/migration70. '; die($msg); } $session_id = session_id(); if(empty($session_id)){ @session_start(); } $GLOBALS = true; define('SUGARCRM_IS_INSTALLING', $GLOBALS);

My PHP version is:
'; $msg .= 'Although the minimum PHP version required is '; $msg .= constant('SUITECRM_PHP_MIN_VERSION').', '; $msg .= 'is not recommended due to the large number of fixed bugs, including security fixes, '; $msg .= 'released in the more modern versions.
'; $msg .= 'You are using PHP version '. constant('PHP_VERSION').', which is EOL: php.net/eol.php.
'; $msg .= 'Please consider upgrading your PHP version. Instructions on php.net/migration70. '; die($msg); } $session_id = session_id(); if(empty($session_id)){ @session_start(); } $GLOBALS = true; define('SUGARCRM_IS_INSTALLING', $GLOBALS);

I am stumped. Can anyone help me?
Werner
The administrator has disabled public write access.

Cannot run install.php for initial installation 1 month 3 weeks ago #70850

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 7856
  • Thank you received: 1220
  • Karma: 284
The first thing I noticed was that the config_override.php file DOES NOT EXIST. Maybe that is why the error message is directed to null.

You are correct. That file is created after the installation. These commands are meant to be usable both before and after installation, thus they have that little redirect.

About the rest, it is really unusual. Something is very broken and throws SuiteCRM code on to the screen.

A few things you can check:

- make sure your web server user name (the one Apache is using) is really www-data, otherwise those chowns aren't correct

- check your PHP version against the Compatibility Matrix: docs.suitecrm.com/admin/compatibility-matrix/

- maybe re-download SuiteCRM to make sure the files are not corrupted

Which version of Ubuntu are you using? For 16.04.x there is a list of modules required here:

suitecrm.com/suitecrm/forum/installation...ubuntu-16-04-1#45976

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Cannot run install.php for initial installation 1 month 3 weeks ago #71067

  • wlstolzus
  • wlstolzus's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Thanks for your reply.
I did figure this out. It turns out my LAMP installation was not quite complete. I did not manage to tell Apache to enable PHP, so it was not actually trying to run the installation code.

Once I enabled PHP in Apache, then I was able to install the application.
The administrator has disabled public write access.

Cannot run install.php for initial installation 1 month 3 weeks ago #71072

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 7856
  • Thank you received: 1220
  • Karma: 284
Ok, cool. I am glad you got it working! :-)

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.
Time to create page: 0.060 seconds
Powered by Kunena Forum