Menu
SuiteCRM dedicated support by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: Configuration variable date.timezone is not set, help wanted to fix :)

Configuration variable date.timezone is not set, help wanted to fix :) 1 year 4 months ago #48759

  • twiggers
  • twiggers's Avatar
  • Offline
  • New Member
  • Posts: 10
  • Karma: 0
Hi all,

Having a bit of bother trying to resolve the following suitecrm.log file issue:


"Mon Jun 12 19:22:58 2017 [1974][-none-][FATAL] Configuration variable date.timezone is not set, guessed timezone Europe/London. Please set date.timezone="Europe/London" in php.ini!"

Well, I've tried adding the above to my php.ini file, both with and without the quotes with no luck.

I'm running SuiteCRM 7.8.2 on Debian 8.7.1 if that helps...

Any help would be really appreciated, 'cos this error is swamping my log file! :(

Thanks,

Andy
The administrator has disabled public write access.

Configuration variable date.timezone is not set, help wanted to fix :) 1 year 4 months ago #48784

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 7883
  • Thank you received: 1221
  • Karma: 286
There is more than one php.ini in your system - one for the web server, and one for the command-line (CLI).

Those errors are probably coming from the CLI whenever a cron job runs (like every minute!).

To locate the several php.ini files in your system, you can use
sudo find / -name php.ini 2>/dev/null

To see which php.ini file your CLI is using, type
php -i | grep php.ini

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Configuration variable date.timezone is not set, help wanted to fix :) 1 year 4 months ago #48815

  • twiggers
  • twiggers's Avatar
  • Offline
  • New Member
  • Posts: 10
  • Karma: 0
Hi pgr,

Fixed! :cheer:

It was the Apache2 php.ini that was the culprit!

both php.ini files have Europe/London added (without quotes)...

And my logfile is...quiet!

Thanks very much.

Cheers.

Andy
The administrator has disabled public write access.
Time to create page: 0.043 seconds
Powered by Kunena Forum