Menu
Welcome, Guest
Username: Password: Remember me

TOPIC: dateTime is not displaying seconds

dateTime is not displaying seconds 1 week 2 days ago #90462

  • dayalv
  • dayalv's Avatar
  • Offline
  • Junior Member
  • Posts: 32
  • Karma: 0
i am using suitecrm Version 7.11.5

in suitecrm, i am not able to view the date with seconds, and also in the locale setting, the time format doesn't have the seconds . pls find the attachent for reference.
Attachments:
The administrator has disabled public write access.

dateTime is not displaying seconds 1 week 2 days ago #90464

  • cherub-chum
  • cherub-chum's Avatar
  • Offline
  • SuiteCRM Is My Life
  • SuiteCRM Dev
  • Posts: 333
  • Thank you received: 57
  • Karma: 16
Do you need to show ALL datetime fields with Seconds? or you need to show only one specific field in your module?
Everything seems impossible, until its done.

Skype : cherubchum
The administrator has disabled public write access.

dateTime is not displaying seconds 1 week 21 hours ago #90470

  • dayalv
  • dayalv's Avatar
  • Offline
  • Junior Member
  • Posts: 32
  • Karma: 0
i need to show all datetime fields in all kinds of layouts such as listview, detailview and edit view. and also if you explain me , how to customize the datetime field in a particular module, it would be much helpful.
Last Edit: 1 week 21 hours ago by dayalv.
The administrator has disabled public write access.

dateTime is not displaying seconds 1 week 6 hours ago #90498

  • cherub-chum
  • cherub-chum's Avatar
  • Offline
  • SuiteCRM Is My Life
  • SuiteCRM Dev
  • Posts: 333
  • Thank you received: 57
  • Karma: 16
There are two things you can do to make it Work. First in the config.php file change the value as follows
'default_time_format' => 'h:i:sa',

Secondly a dirty hack that i did is to change a One Code file used to display date time.

In the core file include/TimeDate.php there is a function called get_time_format
You can set the value by replacing the line
$timef = $user->getPreference('timef');

to 

$timef = 'h:i:sa';

Please note that this is NOT an upgrade safe and correct method but as we also have set the Value in Config, l would expect CRM User Preferences picks that format as sets the format for all new users.
Everything seems impossible, until its done.

Skype : cherubchum
The administrator has disabled public write access.

dateTime is not displaying seconds 6 days 15 hours ago #90505

  • dayalv
  • dayalv's Avatar
  • Offline
  • Junior Member
  • Posts: 32
  • Karma: 0
@cherub-chum, will make a try and let you know
The administrator has disabled public write access.
Time to create page: 0.055 seconds
Powered by Kunena Forum