Menu
Welcome, Guest
Username: Password: Remember me

TOPIC: Tax rate in pdf quotes always shows 0% - a bug?

Tax rate in pdf quotes always shows 0% - a bug? 1 week 6 days ago #89086

  • smartsuitecrm
  • smartsuitecrm's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
Hi,

I am a new suitecrm user, very impressed by the crm - but I need to include the applied tax rate / VAT percentage in my quotes and the following error really leads me to despair:

The tax rate in pdf quotes always shows 0% - in the "Tax" field of the service and products line items. The tax amount is correct.

It doesn't matter which tax percentage I chose before during the quote creation - for example I chose "0,19%" in the dropdown list next to the "TaxAmount" field.

The tax amount ( "$tax_amount") is calculated correctly according to the selected percentage and included in the created PDF quote - but in the service line "Tax" field ("$aos_services_quotes_vat") it shows "0%"

Maybe these details are important:

In the PDF template the "Tax" field in the service line item row includes the place holders "$aos_services_quotes_vat" (and "$aos_products_quotes_vat") - and in the created PDF the field always displayed "0"%

In the vertical "tax" field withe the placeholder "$tax_amount" the correct amount is displayed.

During the quote creation in the "LINE ITEMS" area I clicked on "Add Group", then "Add service line", then I typed in a individual service description, and added a price in the "List" field. Then the tax is calculated correctly.

And I have changed the standard vat_list before in the DropdownEditor and create these 3 new list items:

1. Item Name: "19.0" and Display Label "0,19%"

2. "7.0" and "0,07%"

3. "0.0" and "0,00%"

Is it a bug? Have I overlooked something?

How can I display the used tax / VAT percentage in the PDF quotes?

It would be great if somebody could help to find a solution.


Best regards!


PS:
Suitecrm version Version 7.11.7 / Sugar Version 6.5.25 (Build 344)
Language: German
The administrator has disabled public write access.

Tax rate in pdf quotes always shows 0% - a bug? 1 week 2 days ago #89237

  • smartsuitecrm
  • smartsuitecrm's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
Ok - I found out the solution for myself (maybe it will help others with the same issue that tax percentages in pdf quotes displays always "0%" or no correct values):

1. Important: The tax percentages are related to the decimal places which you set in > Profile > Advanced > Currency Significant Digits. For me (and the most of you) the right value her is "2" (I need cents in my prices etc and it also was the default setting in my installation, so nothing to change here)

2. BUT: In my case when I looked in the vat_list (> Admin > Dropdown Editor > vat_list) the default values of the Display Names over there were "0,20%", "0,05%" or "0,18%" - you see the decimal places?

3. The solution: Change these values to "20%", "5%" and "18%" - AND EVERTHING IS FINE AND YOU WILL GET THE RIGHT TAX PERCENTAGES IN THE PDF QUOTES!

Best regards
Last Edit: 1 week 2 days ago by smartsuitecrm.
The administrator has disabled public write access.

Tax rate in pdf quotes always shows 0% - a bug? 1 week 2 days ago #89248

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10932
  • Thank you received: 1635
  • Karma: 371
It's interesting to know where the error comes from.

But is that really happening with default values?

This is what I see in the live demo:



So those other values that you listed, "0,20%", "0,05%" or "0,18%", aren't they a previous customization you had done in your company?

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.
The following user(s) said Thank You: smartsuitecrm

Tax rate in pdf quotes always shows 0% - a bug? 1 week 1 day ago #89294

  • smartsuitecrm
  • smartsuitecrm's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
Ok, I think together we can identify the cause - it seems to be the "Language" option in the vat_list:

In the live demo vat_list English is the activated language - but I use the German language pack in SuiteCRM and in my vat_list settings "Deutsch (Germany) - de_DE" is activated too. Language pack installed over here: crowdin.com/project/suitecrmtranslations

And in vat_list German the default values are as described above: 0,20%", "0,05%" or "0,18%"
Last Edit: 1 week 1 day ago by smartsuitecrm.
The administrator has disabled public write access.
The following user(s) said Thank You: pgr

Tax rate in pdf quotes always shows 0% - a bug? 1 week 6 hours ago #89342

  • horus68
  • horus68's Avatar
  • Offline
  • SuiteCRM Is My Life
  • Posts: 575
  • Thank you received: 145
  • Karma: 30
Will look into this in the next days to see if its a language issue
|| SuiteCRM in your language crowdin.com/project/suitecrmtranslations ||
|| FAQ - Install/Update languages sites.google.com/site/translatingsuitecrm/faq ||
The administrator has disabled public write access.
The following user(s) said Thank You: pgr, smartsuitecrm
Time to create page: 0.037 seconds
Powered by Kunena Forum