Menu
SuiteCRM Pull Request Party hosted by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: Automatic import of e-mails after Upgrade not function

Automatic import of e-mails after Upgrade not function 1 week 2 days ago #79094

  • sga
  • sga's Avatar
  • Offline
  • New Member
  • Posts: 10
  • Thank you received: 1
  • Karma: 0
Hello

SuiteCRM Version 7.11.2
Sugar Version 6.5.25 (Build 344)

After updating to Version 7.11.2, the automatic import of e-mails for group mailboxes suddenly no longer works.

When I open a mail from a group mailbox, I can import it manually and it works. But the automatic import doesn't work anymore.
You can see the error:
[7112][1][WARN] An Imap error detected: "IMAP expunge error"
in the Errorlog.
The Log is attached

We have Exchange 2007 version 08.03.0485.001 in use. Yes, this is an ancient version, but it can't be changed so fast.

Before the update it worked tip top. Therefore I don't assume that the problem is suddenly related to the exchange server.

What can we do?

Many thanks for the help.

Greetings Samigasi

Translated with www.DeepL.com/Translator
Attachments:
The administrator has disabled public write access.

Automatic import of e-mails after Upgrade not function 1 week 1 day ago #79117

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 9342
  • Thank you received: 1409
  • Karma: 340
You are using XAMPP....

I would focus on this, to start:
Warning [2]: Declaration of 
AOPInboundEmail::handleCreateCase(Email $email, $userId) should be compatible with 
InboundEmail::handleCreateCase($email, $userId) in 
C:\\xampp\\htdocs\\E00suitecrm\\modules\\InboundEmail\\AOPInboundEmail.php auf Zeile 27

Warning [2]: imap_append() expects at least 3 parameters, 1 given in 
C:\\xampp\\htdocs\\E00suitecrm\\include\\Imap\\ImapHandler.php auf Zeile 456

Which version of SuiteCRM are you upgrading from?

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
Last Edit: 1 week 1 day ago by pgr.
The administrator has disabled public write access.

Automatic import of e-mails after Upgrade not function 1 week 1 day ago #79118

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 9342
  • Thank you received: 1409
  • Karma: 340
Can you try changing this line

github.com/salesagility/SuiteCRM/blob/ma...boundEmail.php#L3585

to add the "Email" word after the parenthesis, like so:
public function handleCreateCase(Email $email, $userId)

Tell me

1. If this makes the warning above stop from appearing in the logs
2. If it solves your problem

Thanks

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Automatic import of e-mails after Upgrade not function 6 days 3 hours ago #79141

  • sga
  • sga's Avatar
  • Offline
  • New Member
  • Posts: 10
  • Thank you received: 1
  • Karma: 0
Hello

Thank you so much for your help.

Yes, we still have Xampp in action.
But this will be replaced in the long run.

I have inserted the code.
Since we don't receive daily mails, I can give feedback only in a few days.

friendly greetings
The administrator has disabled public write access.

Automatic import of e-mails after Upgrade not function 6 days 1 hour ago #79150

  • sga
  • sga's Avatar
  • Offline
  • New Member
  • Posts: 10
  • Thank you received: 1
  • Karma: 0
Hello

Now I can answer the questions:
1. the error mentioned above is partially gone. The error concerning ImapHandler is still present
2. no the automatic import does not work yet.

I have the code in the directory:
C:\xampp\htdocs\suitecrm\modules\InboundEmail\InboundEmail.php
changed. Is that correct?

We have two SuiteCRM directories:
  • htdocs\suitecrm
  • and htdocs\E00suitecrm
The directory E00suitecrm is a test environment.
Sorry, I forgot to mention that.

Could it have something to do with it?
github.com/salesagility/SuiteCRM/commit/...80defbfecef7a0295a66

The current log is attached.

Greetings
Attachments:
The administrator has disabled public write access.

Automatic import of e-mails after Upgrade not function 5 days 22 hours ago #79156

  • sga
  • sga's Avatar
  • Offline
  • New Member
  • Posts: 10
  • Thank you received: 1
  • Karma: 0
Hello

We've found the solution.

We found the recommendation of afnieves in bug #6888 7.10.12 Auto Import of Emails not working implemented and it worked.


The solution is attached as an image.

If solved.

Greetings
Attachments:
The administrator has disabled public write access.
The following user(s) said Thank You: pgr
Time to create page: 0.102 seconds
Powered by Kunena Forum