Menu
SuiteCRM Pull Request Party hosted by SalesAgility
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: v7.11.1 - Campaign email variables fail: [ERROR] Unable to find relationship emails_email_templates

v7.11.1 - Campaign email variables fail: [ERROR] Unable to find relationship emails_email_templates 1 month 2 days ago #82090

  • stephenmchugh
  • stephenmchugh's Avatar
  • Offline
  • Senior Member
  • Posts: 54
  • Thank you received: 5
  • Karma: 0
I got Lead variables to work!!!! Props to 'sru001' on Github, post github.com/salesagility/SuiteCRM/issues/6535)

It seems so obvious now:

lead_first_name: $lead_first_name

lead_last_name: $lead_last_name

lead_name: $lead_name
The administrator has disabled public write access.

v7.11.1 - Campaign email variables fail: [ERROR] Unable to find relationship emails_email_templates 1 month 2 days ago #82096

  • stephenmchugh
  • stephenmchugh's Avatar
  • Offline
  • Senior Member
  • Posts: 54
  • Thank you received: 5
  • Karma: 0
BTW, note that Target variables still use the old "prospects." naming:

Target first name: $prospect_first_name

Target last name: $prospect_last_name

Target name: $prospect_name

etc.

etc.
The administrator has disabled public write access.

v7.11.1 - Campaign email variables fail: [ERROR] Unable to find relationship emails_email_templates 3 weeks 3 days ago #82371

  • SR000
  • SR000's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
@stephenmchugh Thanks, tried to find a quick fix but it's over my head. I expect it to miss a bean identification pass through based on the to send to lead/contact/target.

Hope a fix is found swiftly. Then we can modify all templates again \_/
The administrator has disabled public write access.

v7.11.1 - Campaign email variables fail: [ERROR] Unable to find relationship emails_email_templates 3 weeks 3 days ago #82387

  • stephenmchugh
  • stephenmchugh's Avatar
  • Offline
  • Senior Member
  • Posts: 54
  • Thank you received: 5
  • Karma: 0
We have a mix of Contacts and Leads for our campaigns, so our quick fix for a personalized email looks like this:

"Hi $lead_first_name$contact_first_name, yada yada........"

(note that you don't need a space between '$lead_first_name' and '$contact_first_name')

Works fine.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.040 seconds
Powered by Kunena Forum