Menu
SuiteCRM dedicated support by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: Setting file permissions from an FTP Server

Setting file permissions from an FTP Server 1 week 16 hours ago #74042

  • Princeps of Nihils
  • Princeps of Nihils's Avatar
  • Offline
  • Premium Member
  • Posts: 111
  • Thank you received: 3
  • Karma: 1
Hi everyone

My Server uses a different launguage style (bash), I am the root user and it goes just beyond my capabilities to set the permissions correctly or check they are set.

I normally do most of mmy work through FTP Servers. But cannot find a recent (with 4 years or bespoke to Suite) instructions on how to set the file permissions in Suite from the FTP.

Can anyone give me some simple step by step instructions on what needs to be set to what from an FTP.

Thank you :)

Princeps
I use Version 7.10.7 attempting to upgrade to 7.10.10.

“One-Eye’s handicap in no way impairs his marvelous hindsight."
The administrator has disabled public write access.

Setting file permissions from an FTP Server 6 days 17 hours ago #74048

  • Princeps of Nihils
  • Princeps of Nihils's Avatar
  • Offline
  • Premium Member
  • Posts: 111
  • Thank you received: 3
  • Karma: 1
I ensured the following directories are set to 775

- cache
- custom
- modules
- themes
- data
- upload

775 for file config_override.php but do not know how to set it 2>/dev/null from the FTP.


I spoke to my webhost who advised me I need to know the directory in order to implement the permission instructions from docs.suitecrm.com/admin/installation-gui...loading--installing/ which really threw me.

Princeps
I use Version 7.10.7 attempting to upgrade to 7.10.10.

“One-Eye’s handicap in no way impairs his marvelous hindsight."
The administrator has disabled public write access.

Setting file permissions from an FTP Server 6 days 11 hours ago #74081

  • Princeps of Nihils
  • Princeps of Nihils's Avatar
  • Offline
  • Premium Member
  • Posts: 111
  • Thank you received: 3
  • Karma: 1
Hi Everyone

I did not manage to solve the issue using my FTP server.

I did solve it by working out why my instructions did not work. This caused me SOOO many permissions issues! Error codes everywhere.

Context: I have a completely new server with ROOT and I did not have it configured with Users. I was entering the commands as root and the command syntax is different than if you are entering it as a user.

1. I needed to set up a user for the commands from docs.suitecrm.com/admin/installation-gui...loading--installing/ to work.

I did this by following these awesome instructions: access.redhat.com/documentation/en-US/Re...d_Guide/ch02s03.html

2. I then granted the user I created access to the files using
chown -R [i]User[/i].[i]Group[/i]
**then the filepath of my SuiteCRM Server*

3. I then ran
sudo chown -R www-data:www-data .
  sudo chmod -R 755 .
  sudo chmod -R 775 cache custom modules themes data upload
  sudo chmod 775 config_override.php 2>/dev/null

I think the instructions on the main site for running permissions needs to have a second part for people running their own servers for the first time. More people now can access servers very cost effectively and Suite does not really require a huge amount of knowledge beyond install and permissions.

This would not cost much and would really be useful for building the community.

Most of my issues have been a result of permissions not being run correctly and this was the reason.

I hope this helps people in future.

Princeps
I use Version 7.10.7 attempting to upgrade to 7.10.10.

“One-Eye’s handicap in no way impairs his marvelous hindsight."
The administrator has disabled public write access.
Time to create page: 0.058 seconds
Powered by Kunena Forum