Menu
SuiteCRM dedicated support by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: Not able to get Schedulers to work "on time"

Not able to get Schedulers to work "on time" 1 month 4 weeks ago #71733

  • jlabuelo
  • jlabuelo's Avatar
  • Offline
  • Senior Member
  • Posts: 56
  • Thank you received: 1
  • Karma: 0
Hello all

We are using SuiteCRM 7.9.8 but we have a problem with a custom Scheduler job we have created.
We would like to get it executed every 30 mins from 9:00 AM to 18:30 PM from Mondays to Fridays, however when we set up this configuration in the Scheduler, it does not work. (Please see image1 attached).



We are able to get t to work when we click in the option "Executed if Missed", however this executes the job every minute (as it is configure in the Ubuntu Cron) (See image2 attached).



How can we get the Scheduler to work as we have planned in its configuration?




Thanks a lot
The administrator has disabled public write access.

Not able to get Schedulers to work "on time" 1 month 4 weeks ago #71735

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 8246
  • Thank you received: 1265
  • Karma: 298
I think you need a clean-up of your database. You have too many records of previous execution, this is probably causing any queries to that label to fail.

You said the job "doesn't work", but if you can specify what exactly happens (nothing? an error?) it would be better.

Please include anything relevant from both your logs:

suitecrm.log
php_errors.log

Also, try running the first query in this post:

pgorod.github.io/Database-tables-size/

This will make it evident if the tables are overgrown, then we can work on the clean-up.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Not able to get Schedulers to work "on time" 1 month 3 weeks ago #72032

  • jlabuelo
  • jlabuelo's Avatar
  • Offline
  • Senior Member
  • Posts: 56
  • Thank you received: 1
  • Karma: 0
Hello Guys

I have done what you suggested. It is true, db was full of completed jobs, however after removing them, and also disable the option "Execute if missed", nothing happens, no errors in php_error files, no erros in Suitecrm log files....

If I enable "Execute if missed" back again, job is run fine every "minute".

Any suggestion please?

Thanks so much in advance!
The administrator has disabled public write access.

Not able to get Schedulers to work "on time" 1 month 3 weeks ago #72036

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 8246
  • Thank you received: 1265
  • Karma: 298
I'd like to see if there are any particularly slow queries taking place. You can turn on "log slow queries" in Admin / System settings.

You can also try raising your log level to DEBUG (in Admin / System Settings) and use "tail -f suitecrm.log" in a separate console window to track the execution.

This is better when there are no users using the system (like on a weekend?) so that only the Scheduler's traffic appears there.

Also, if you can disable the other Jobs, output will be much simpler.

You can press "enter" in that console a few times to leave some blank lines, to mark when things were executed, or when things were stopped for a while. Then you can go back and examine the output.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.
Time to create page: 0.086 seconds
Powered by Kunena Forum