Menu
SuiteCRM dedicated support by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: SMTP connect() failed.

SMTP connect() failed. 2 months 6 days ago #69245

  • kishah2411
  • kishah2411's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
I have issue in Outbound Email.
Some days before Email Setting working properly.

Suddenly setting is not working. I am checking and reset all setting but facing following error in log:

SugarPHPMailer encountered an error: SMTP Error: Could not authenticate.


Please help me related this issue
The administrator has disabled public write access.

SMTP connect() failed. 2 months 6 days ago #69249

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 7433
  • Thank you received: 1156
  • Karma: 267
What is your SuiteCRM version?

What did you change to make it stop working? Did you upgrade?

That error is coming from your email server. It's typically caused by a wrong password... if you go into the email settings, and try the "send test email" button, and it fails, you get a link to an extended log that might help you figure out the cause.
The administrator has disabled public write access.

SMTP connect() failed. 2 months 6 days ago #69254

  • kishah2411
  • kishah2411's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
I am using SuiteCRM v 7.9.7

I have not upgrade suite in between working and not working email setting.

Same Email setting working in another suite with same version.

Yes May be last log due to wrong password

but another log is:
-->  SugarPHPMailer encountered an error: An outgoing mail server is not configured to send emails. Please configure an outgoing mail server or select an outgoing mail server for the mail account that you are using in Settings >> Mail Account.
--> SugarPHPMailer encountered an error: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
Last Edit: 2 months 6 days ago by kishah2411. Reason: Need to update line
The administrator has disabled public write access.

SMTP connect() failed. 2 months 6 days ago #69256

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 7433
  • Thank you received: 1156
  • Karma: 267
In the "Send Test Email" button, do you see a link saying "SMTP Full log" when it fails?
The administrator has disabled public write access.

SMTP connect() failed. 2 months 1 day ago #69442

  • hoasenvang7799
  • hoasenvang7799's Avatar
  • Offline
  • Junior Member
  • I want a banana
  • Posts: 31
  • Thank you received: 3
  • Karma: 0
Hello Mr @pgr
I do not know how to describe it, with version 7.10.5 emailing with SMTP is perfect. However, when upgrade to version 7.10.7, will not be able to send emails. error related to class.smtp.php
3: Connection: opening to ssl://smtp.yandex.com:465, timeout=300, options=array (
)
3: Connection failed. Error #2: stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed [/home/myaccounthere/public_html/suitecrm.yesdomain.com/include/phpmailer/class.smtp.php line 298]
3: Connection failed. Error #2: stream_socket_client(): Failed to enable crypto [/home/myaccounthere/public_html/suitecrm.yesdomain.com/include/phpmailer/class.smtp.php line 298]
3: Connection failed. Error #2: stream_socket_client(): unable to connect to ssl://smtp.yandex.com:465 (Unknown error) [/home/myaccounthere/public_html/suitecrm.yesdomain.com/include/phpmailer/class.smtp.php line 298]
1: SMTP ERROR: Failed to connect to server:  (0)
3: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

* I tried changing to Google Mail but could not improve the situation!
Please help me for this issue. Thanks
Enjoy and passionate Open Source
The administrator has disabled public write access.

SMTP connect() failed. 2 months 1 day ago #69448

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 7433
  • Thank you received: 1156
  • Karma: 267
Check your server certificate. Or get one with Let's Encrypt, if you don't have one already.

I don't know exactly what changed in that upgrade, probably a new version of phpmailer inside SuiteCRM. It is also possible that your certificate simply expired around the same time.

But that error is coming from the server, and it's a SSL error.
The administrator has disabled public write access.

SMTP connect() failed. 1 month 2 weeks ago #70056

  • hoasenvang7799
  • hoasenvang7799's Avatar
  • Offline
  • Junior Member
  • I want a banana
  • Posts: 31
  • Thank you received: 3
  • Karma: 0
@pgr this is erro :: Error:SMTP Error: Could not authenticate.
i could not found any topic for my case, sorry this forum also on Github, look at that, Gmail with certificate i think there is no problem. Or get one with Let's Encrypt i've just renew one. it's oki. I tried change to 3 email provider with SSL and TLS - can not find a solution for this (7.10.5 and 7.10.6 immunity - same server, same code, nothing change )
Thank you so much!
Enjoy and passionate Open Source
The administrator has disabled public write access.

SMTP connect() failed. 1 month 2 weeks ago #70067

  • yahyanawab
  • yahyanawab's Avatar
  • Offline
  • New Member
  • Posts: 11
  • Thank you received: 2
  • Karma: 0
Hi kishah2411

> Create New Outbound Email account,
> SMTP Server Name : smtp.gmail.com
> chech "SMTP Auth" check box
> SMTP Port 587
> SMTP Protocol : TLS
> correctly fill your Username and password.

After that test your email click on send test email

work correctly :)
The administrator has disabled public write access.
Time to create page: 0.064 seconds
Powered by Kunena Forum