Menu
SuiteCRM dedicated support by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: email from name showing as "Root User" when received

email from name showing as "Root User" when received 3 months 1 week ago #67478

  • Andyg
  • Andyg's Avatar
  • Offline
  • Junior Member
  • Posts: 34
  • Thank you received: 2
  • Karma: 0
After upgrading to 7.10.6 from 7.10.5 it seems I am now able to send email using the system account but with one minor problem.

If I go to Admin / Email Settings and Send Test Email it works great and when received all appears to be fine. If I go to a contact or account click on the email address to send an email from there everything looks fine too, but when the email is received at the other end the From name is showing as "Root User" rather than "My Company Name" which is what shows in SuiteCRM before clicking send.

I did previously post this as a reply to a related older thread, but I thought it might be better to post it as a new thread as it is a slightly different problem.

Thanks for any ideas.

Andy
The administrator has disabled public write access.

email from name showing as "Root User" when received 3 months 1 week ago #67494

  • 3boptic
  • 3boptic's Avatar
  • Offline
  • Senior Member
  • Posts: 67
  • Thank you received: 8
  • Karma: 1
The same here. Andyg, would you mind adding an issue on GitHub and posting the link here?
SuiteCRM v 7.10.8
MySQL 5.7 Percona Server
Apache 2 / PHP 7.1 FPM
Ubuntu 17.10
Google Chrome 69.0.3497.92 (Build oficial) (64 bits)
The administrator has disabled public write access.

email from name showing as "Root User" when received 3 months 1 week ago #67528

  • stefanom
  • stefanom's Avatar
  • Offline
  • New Member
  • Posts: 15
  • Thank you received: 3
  • Karma: 0
The same issue here, too. FromName is set to "Root User" here:
github.com/salesagility/SuiteCRM/blob/e0...ss.phpmailer.php#L79

and then, after this commit, is not modified anymore when using the system email:
github.com/salesagility/SuiteCRM/commit/...ab9593cb4ec0cb191646

Quick fix: edit line 79 of .../include/phpmailer/class.phpmailer.php and put the "Company Name" instead of "Root User"
The administrator has disabled public write access.

email from name showing as "Root User" when received 3 months 1 week ago #67608

  • Andyg
  • Andyg's Avatar
  • Offline
  • Junior Member
  • Posts: 34
  • Thank you received: 2
  • Karma: 0
Posted this as an issue on Github: github.com/salesagility/SuiteCRM/issues/6012

Hopefully I did it right.

Andy
The administrator has disabled public write access.

email from name showing as "Root User" when received 3 months 6 days ago #67679

  • Andyg
  • Andyg's Avatar
  • Offline
  • Junior Member
  • Posts: 34
  • Thank you received: 2
  • Karma: 0
I have closed the Github issue I created above as I noticed issue: github.com/salesagility/SuiteCRM/pull/6017 which would not only resolve this problem, but be a far better solution.

Andy
The administrator has disabled public write access.

email from name showing as "Root User" when received 2 months 4 weeks ago #68061

  • 3boptic
  • 3boptic's Avatar
  • Offline
  • Senior Member
  • Posts: 67
  • Thank you received: 8
  • Karma: 1
Hi Andyg,

I have implemented pull request #6017 and the Root User error remained the same. Have you tried this solution yet? Did you get another result?

Changing the hardcoded variable in class.phpmailer.php did work well.

Thank you
SuiteCRM v 7.10.8
MySQL 5.7 Percona Server
Apache 2 / PHP 7.1 FPM
Ubuntu 17.10
Google Chrome 69.0.3497.92 (Build oficial) (64 bits)
Last Edit: 2 months 4 weeks ago by 3boptic.
The administrator has disabled public write access.

email from name showing as "Root User" when received 2 months 3 weeks ago #68381

  • Andyg
  • Andyg's Avatar
  • Offline
  • Junior Member
  • Posts: 34
  • Thank you received: 2
  • Karma: 0
@3boptic I did implement those changes manually as per #6017 on v7.10.6 and it solved the problem for me. I haven't upgraded to 7.10.7 yet though, thought I'd hold off a little longer before trying it this time as I'm fairly busy with other stuff too.

Andy
The administrator has disabled public write access.
The following user(s) said Thank You: 3boptic

email from name showing as "Root User" when received 2 months 1 week ago #68980

  • AlanS
  • AlanS's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Has anyone figured this out?

I'm on 7.10.7 and implemented the change in #6017 to no avail. I no longer get "root user" but I always just get an e-mail with no "From name" field. So, all of my e-mails just show up as "alan". I'm not sure what the difference between the "Send Test E-mail" button and sending an e-mail from within the editor in SuiteCRM is, but the send test e-mail routine seems to be properly pulling the "From name".

I think this may relate to why I can use SMTP auth to send e-mail, but, if I try to set-up an SMTP relay, the server rejects the e-mail. The smtp relay also works with the "Send Test E-mail" as an admin user, but then fails to allow me to compose an email in the Suite editor.
The administrator has disabled public write access.

email from name showing as "Root User" when received in version 7.10.6 and now in version 7.10.7 as well 2 months 1 week ago #69179

  • Jacob196
  • Jacob196's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Thank you received: 1
  • Karma: 0
And Im very interested too.

Have had the same problem since ver. 7.10.15 - tried the #6017 fix, but with no change.

From name "Root User" is not professional.

Please help :dry:

BR
Jacob
The administrator has disabled public write access.

email from name showing as "Root User" when received 2 months 1 week ago #69199

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 7433
  • Thank you received: 1156
  • Karma: 267
That Root user is definitely a bug. There is an easy workaround (untested, but I bet it will work) in case you can replace that string with a single value:

Change this line in the code to put in a different From Name:
include/phpmailer/class.phpmailer.php:79:    public $FromName = 'Root User';

This will apply to every user throughout the system that is experiencing this bug, so this solution won't be good for some cases. But at least you can put your Company's name or something.
The administrator has disabled public write access.
The following user(s) said Thank You: Jacob196

email from name showing as "Root User" when received 2 months 6 days ago #69226

  • Jacob196
  • Jacob196's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Thank you received: 1
  • Karma: 0
Hi pgr.

That helped alot - tnx.

Im very greatfull.

BR

Jacob
The administrator has disabled public write access.

email from name showing as "Root User" when received 1 month 2 weeks ago #70183

  • wondertrout
  • wondertrout's Avatar
  • Offline
  • New Member
  • Posts: 10
  • Thank you received: 1
  • Karma: 0
Totally weird. This was working correctly for me and then all of a sudden changed to Root User. Repair and quick rebuild and rebuild incoming mail accounts did not fix. But nothing has changed as far as I know. I did previously send out emails directly from contact records and then tried from both campaigns (which crashed with a return to the dashboard page - but that's another story) and from the email module directly. Totally weird...
The administrator has disabled public write access.
Time to create page: 0.071 seconds
Powered by Kunena Forum