Menu
SuiteCRM Pull Request Party hosted by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: activity stream - 7.10.5

activity stream - 7.10.5 1 year 3 weeks ago #66800

  • Adriano_ABC
  • Adriano_ABC's Avatar
  • Offline
  • Premium Member
  • Posts: 135
  • Thank you received: 10
  • Karma: 2
After updating to 7.10.5, all news feeds in the activity stream, even the old ones, are marked as being created in "0 seconds."


The administrator has disabled public write access.

activity stream - 7.10.5 1 year 3 weeks ago #66807

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10244
  • Thank you received: 1533
  • Karma: 353
Here you go, there's an Issue and a proposed fix! :-)

github.com/salesagility/SuiteCRM/issues/5918

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.
The following user(s) said Thank You: Timo12357

activity stream - 7.10.5 1 year 3 weeks ago #66819

  • Adriano_ABC
  • Adriano_ABC's Avatar
  • Offline
  • Premium Member
  • Posts: 135
  • Thank you received: 10
  • Karma: 2
Thank you, it worked.
The administrator has disabled public write access.

activity stream - 7.10.5 1 year 2 weeks ago #67314

  • Gaudet
  • Gaudet's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
I had the same issue after upgrading to 7.10.5 ( 0 seconds everywhere). Updating to 7.10.6 did not solve the situation. Instead, my activity stream show 2526 weeks and 6 days ago to all activities.
The administrator has disabled public write access.

activity stream - 7.10.5 11 months 1 week ago #69452

  • evanevgram
  • evanevgram's Avatar
  • Offline
  • Senior Member
  • Posts: 44
  • Thank you received: 2
  • Karma: 0
I'm on 7.10.7 and my activity stream time does not update. A post made on it just says 0 seconds ago the whole time.
The administrator has disabled public write access.

activity stream - 7.10.5 11 months 1 week ago #69454

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10244
  • Thank you received: 1533
  • Karma: 353
Can you guys try the latest commits in github.com/salesagility/SuiteCRM/issues/5918 ?

I wonder if the solution only works for new items in the Stream? Maybe the stuff that entered the Stream while the bug was present, didn't get saved correctly. Try adding new stuff and check if it works well.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.
The following user(s) said Thank You: evanevgram

activity stream - 7.10.5 11 months 1 week ago #69456

  • evanevgram
  • evanevgram's Avatar
  • Offline
  • Senior Member
  • Posts: 44
  • Thank you received: 2
  • Karma: 0
Aha yep... replacing modules/SugarFeed/SugarFeed.php with the one in the fix seemed to do the trick.
The administrator has disabled public write access.
The following user(s) said Thank You: pgr

activity stream - 7.10.5 4 months 1 week ago #77627

  • mcom
  • mcom's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Thank you received: 1
  • Karma: 0
Does anyone know if there was reason this was not also changed in Version 7.8.26? Since at least 7.8.22, the activity stream read 0 Hours 0 Minutes ago for all entries new and historic. I replaced the "static function getTimeLapse($startDate)" function with the pull request #6033 code and the new and historic times are now correctly displayed again.
The administrator has disabled public write access.

activity stream - 7.10.5 4 months 1 week ago #77630

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10244
  • Thank you received: 1533
  • Karma: 353
@mcom I commented in that PR, maybe you're right and we neglected to put this into 7.8.x...

github.com/salesagility/SuiteCRM/pull/6033

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.
The following user(s) said Thank You: mcom

activity stream - 7.10.5 4 months 1 week ago #77751

  • Dillon-Brown
  • Dillon-Brown's Avatar
  • Offline
  • Administrator
  • Posts: 199
  • Thank you received: 71
  • Karma: 15
Looks like this was missed for 7.8.x. I've created a fix here: github.com/salesagility/SuiteCRM/pull/6937
The administrator has disabled public write access.
The following user(s) said Thank You: pgr, mcom

activity stream - 7.10.5 1 week 19 hours ago #85959

  • holdusback
  • holdusback's Avatar
  • Offline
  • Premium Member
  • Posts: 128
  • Thank you received: 6
  • Karma: 0
Is this normal that this issue is still alive ?

Got SuiteCRM 7.11.5, no error in the console log and got this issue too . Every entry in the chat are "0 sec ago".
The administrator has disabled public write access.

activity stream - 7.10.5 1 week 18 hours ago #85964

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10244
  • Thank you received: 1533
  • Karma: 353
Something's strange here. I just tried this in 7.11.5 and

- Administrator always sees "0 seconds", both for his own entries in chat, and for other people's

- other user sees correct times printed

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.
Time to create page: 0.072 seconds
Powered by Kunena Forum