Menu
SuiteCRM dedicated support by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: Meeting time off by one hour

Meeting time off by one hour 7 months 3 weeks ago #63956

  • razgrizgt
  • razgrizgt's Avatar
  • Offline
  • Senior Member
  • Posts: 41
  • Thank you received: 2
  • Karma: 0
The meeting time seems to be off by one hour. Can anyone produce the same result?

1. Use SuiteCRM demo on their site.
2. Go to Calendar, and create a meeting from 9-10am, save.
3. Edit the meeting, the meeting block seems to be at 10-11am now.

Is it my browser setting, or is this a bug?
The administrator has disabled public write access.

Meeting time off by one hour 7 months 3 weeks ago #63984

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 8555
  • Thank you received: 1307
  • Karma: 311
I tried it on my test install, and on the live demo, and it works well.

It could be your browser, but it could also be your timezone setting.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Meeting time off by one hour 7 months 3 weeks ago #64158

  • razgrizgt
  • razgrizgt's Avatar
  • Offline
  • Senior Member
  • Posts: 41
  • Thank you received: 2
  • Karma: 0
Hi pgr,

Can you try using the share week and look at someone else's Calendar? That's where the problem is happening...
The administrator has disabled public write access.

Meeting time off by one hour 7 months 3 weeks ago #64173

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 8555
  • Thank you received: 1307
  • Karma: 311
What is your timezone?

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Meeting time off by one hour 7 months 3 weeks ago #64174

  • razgrizgt
  • razgrizgt's Avatar
  • Offline
  • Senior Member
  • Posts: 41
  • Thank you received: 2
  • Karma: 0
Central Timezone UTC-6:00 with daylight saving.

If I change my Windows setting to UTC, everything works fine but now my setting it UTC -6:00 with daylight saving, everything is off.

Can you try it with my time zone with daylight saving?
Last Edit: 7 months 3 weeks ago by razgrizgt.
The administrator has disabled public write access.

Meeting time off by one hour 7 months 3 weeks ago #64217

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 8555
  • Thank you received: 1307
  • Karma: 311
Can you test this fix on your system?

It is very similar to what you're experiencing. I was hoping it would fix your problem.

This was fixed some time ago, but unfortunately it wasn't merged into the product yet.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Meeting time off by one hour 7 months 3 weeks ago #64226

  • razgrizgt
  • razgrizgt's Avatar
  • Offline
  • Senior Member
  • Posts: 41
  • Thank you received: 2
  • Karma: 0
github.com/salesagility/SuiteCRM/pull/5456

Do you mean this fix? This fixes the calendar off by one day issue, but there is another issue of meeting off by one hour when view by someone else in shared calendar or your own calendar.

The time block of the added invitee is off by one hour, as the meeting is pushed later one hour.
Attachments:
The administrator has disabled public write access.

Meeting time off by one hour 7 months 3 weeks ago #64229

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 8555
  • Thank you received: 1307
  • Karma: 311
Yes that's the one - sorry I forgot to paste the link.

I guess there's another bug, let me ask for help with one of the developers and I'll get back to you.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.
The following user(s) said Thank You: razgrizgt

Meeting time off by one hour 7 months 3 weeks ago #64232

  • Dillon-Brown
  • Dillon-Brown's Avatar
  • Offline
  • Administrator
  • Posts: 179
  • Thank you received: 55
  • Karma: 12
Hi razgrizgt,

So from what I can see the meetings are appearing correctly in the calendar but not in the scheduler bar? I believe this should be solved by github.com/salesagility/SuiteCRM/pull/4335 but it's been quite a while since that PR was made so it's possible that this is a new issue. Let me know if that PR solves it and if not I can re-investigate.

Thanks.
The administrator has disabled public write access.
The following user(s) said Thank You: razgrizgt

Meeting time off by one hour 7 months 3 weeks ago #64238

  • razgrizgt
  • razgrizgt's Avatar
  • Offline
  • Senior Member
  • Posts: 41
  • Thank you received: 2
  • Karma: 0
Thanks Dillon-Brown,

Didn't see that pull request, hopefully, the two fixes will get merge soon?

Thanks!
The administrator has disabled public write access.

Meeting time off by one hour 7 months 3 weeks ago #64239

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 8555
  • Thank you received: 1307
  • Karma: 311
@razgrizgt it helps if you apply the fixes manually, test, and then leave a comment on Github reporting the results. Thanks!

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.
Time to create page: 0.109 seconds
Powered by Kunena Forum