Menu
SuiteCRM dedicated support by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: Custom PDF Templates are not being used

Custom PDF Templates are not being used 8 months 1 week ago #59817

  • vinkobak
  • vinkobak's Avatar
  • Offline
  • Junior Member
  • Posts: 31
  • Thank you received: 1
  • Karma: 0
Hello everyone!
I have created three PDF Templates for testing purposes - one for each module: Quotes, Invoices and Report. I did it all "by the book" - just followed the steps described in User's Manual. Plain and simple.

If I go to "Print as PDF", the downloaded document is correct by all means except it doesn't look like my custom made template. It looks like none of the custom templates is being used and there is no step for choosing desired template. I have tried with log-out/log-in, permissions repair, Quick repair and rebuild, deleted browser's cache but nothing helped.

I'm on SuiteCRM 7.9.9.
I had a few minor glitches so far but they were mostly permissions related. This is the first time I'm facing something like this. Is it a bug I should report? How can I detect it to be sure?

Thank you all in advance and best regards!
vinkobak
The administrator has disabled public write access.

Custom PDF Templates are not being used 8 months 1 day ago #60229

  • vinkobak
  • vinkobak's Avatar
  • Offline
  • Junior Member
  • Posts: 31
  • Thank you received: 1
  • Karma: 0
Hello again!
Out of lack of answers I came to solution which may point to a bug... As mentioned in previous post, I had three custom templates - one for quotes, one for invoices and one for reports. Clicking on Print to PDF gave me no chooser window to pick desired custom template. I thought it's because I had only one template and that template would be used to produce PDF. But no, that was not the case. PDF was produced with, presumably, default PDF template for Quotes.
After creating another custom template for quotes, clicking on Print to PDF opened floating window with two custom templates to choose from!
Should I report it as a bug?
Best regards!
vinkobak
The administrator has disabled public write access.

Custom PDF Templates are not being used 8 months 1 day ago #60252

  • vinkobak
  • vinkobak's Avatar
  • Offline
  • Junior Member
  • Posts: 31
  • Thank you received: 1
  • Karma: 0
Another update on this topic...
It seems above mentioned "solution" does not work with Reports. I have created two report templates but can't reach template chooser. When a report is created clicking on Download PDF immediately downloads report created with, again presumably, default template.
Still trying to figure out how to get to chooser window or some other way to use my custom report template. Any suggestion is welcome!
Regards,
vinkobak
The administrator has disabled public write access.

Custom PDF Templates are not being used 7 months 4 weeks ago #60425

  • vinkobak
  • vinkobak's Avatar
  • Offline
  • Junior Member
  • Posts: 31
  • Thank you received: 1
  • Karma: 0
Here's what I have learned so far:
User's Manual clearly states it's possible to connect extra modules with PDF Template module (in 'Type' dropdown).
By default the modules you can select are: Quotes Invoices Accounts Contacts Leads.
System Administrator users can extend this list by editing the 'pdf_template_type_dom' using the drop down editor functionality. Please note that the drop down 'Item Name' must be the name of the module directory.
My 'Item Name' is [AOR_Reports] and, unless the module directory is named differently, this should work. Unfortunately it doesn't. If I go on Download PDF in Reports -> Actions, download starts immediately and I can't choose desired template.
Also, in PDF Template Edit view, 'Insert Field' can't be populated.

I suspect there is a problem with module name in 'Item Name' or, for some reason, there is no connection between 'Item Name' and desired module.

I hope after releasing 7.10 some developer would stumble upon this and maybe offer some way out. :)

Best regards,
vinkobak
The administrator has disabled public write access.
The following user(s) said Thank You: rodmontgt

Custom PDF Templates are not being used 2 months 1 week ago #70392

  • rodmontgt
  • rodmontgt's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
vinkobak wrote:
Here's what I have learned so far:
User's Manual clearly states it's possible to connect extra modules with PDF Template module (in 'Type' dropdown).
By default the modules you can select are: Quotes Invoices Accounts Contacts Leads.
System Administrator users can extend this list by editing the 'pdf_template_type_dom' using the drop down editor functionality. Please note that the drop down 'Item Name' must be the name of the module directory.
My 'Item Name' is [AOR_Reports] and, unless the module directory is named differently, this should work. Unfortunately it doesn't. If I go on Download PDF in Reports -> Actions, download starts immediately and I can't choose desired template.
Also, in PDF Template Edit view, 'Insert Field' can't be populated.

I suspect there is a problem with module name in 'Item Name' or, for some reason, there is no connection between 'Item Name' and desired module.

I hope after releasing 7.10 some developer would stumble upon this and maybe offer some way out. :)

Best regards,
vinkobak

I have made a custom PDF template for my custom module, you give an idea of how to resolve this "problem", I have followed your steps and for the item name I wrote the name of the directory (i have connected to my site using FTP and look inside the modules directory, then found the name of the custom module), I have made these steps and voilà, all my fields appeared in Insert Fields dropdown like magic.
Hope this helps
The administrator has disabled public write access.
Time to create page: 0.055 seconds
Powered by Kunena Forum