Menu
SuiteCRM Pull Request Party hosted by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: German Charset is ignored by SuiteCRM

German Charset is ignored by SuiteCRM 2 months 1 week ago #77776

  • tosesystems
  • tosesystems's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
Hi guys,

My SuiteCRM installation won't accept German umlauts. The following problem happens:

If I type one of these: ä, ö, ü --> it is converted into some weird signs (like this for example: ü).

I tried three different ways to solve this problem, but none of them worked. In the following I will descirbe this attempts:

1)

- I installed the german language pack
- Changed the local settings for each user to: ISO-8859-1.
- Furthermore, I changed the charset settings for the whole system to: ISO-8859-1.
- After changing, I did a quick repair. I logged off and logged in again

--> But still the german umlauts won't being accepted.


2) In addition to that, I tried to fix this problem by changing the settings in the config.php and config_override.php.

My config files look like this:


config.php:

'dbconfigoption' =>
array (
'persistent' => true,
'autofree' => false,
'debug' => 0,
'ssl' => false,
'collation' => 'utf8_german2_ci',
),
'default_action' => 'index',
'default_charset' => 'ISO-8859-1',
'default_currencies' =>

....

'default_export_charset' => 'ISO-8859-1',
'default_language' => 'de_DE',



config_override.php:
$sugar_config = 'utf8_german2_ci';
$sugar_config = 'ISO-8859-1';
$sugar_config = 'EUR';
$sugar_config = 'd.m.Y';
$sugar_config = 'de_DE';
$sugar_config = 'Euro';
$sugar_config = '€';


--> But also after these changes, my german umlauts wont being accepted.

3)
Since my database was built with UTF-8, i changed the database collation to: utf8_german2_ci. For this I did the following:

- In myphpadmin I changed the database collation to utf8_german2_ci
- In myphpadmin I applied the collation change to the whole database.
- In SuiteCRM, I changed the database collation to utf8_german2_ci
- I did a quick repair, logged off and logged in again

--> But still nothing with my german umlauts....

Maybe someone can help me.

Thank you very much in advance!

Best regards,
Thomas Seghorn
Last Edit: 2 months 1 week ago by tosesystems.
The administrator has disabled public write access.
Moderators: horus68
Time to create page: 0.084 seconds
Powered by Kunena Forum