Menu
SuiteCRM dedicated support by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: error message when using the french translation

error message when using the french translation 1 week 6 days ago #72635

  • Livaille
  • Livaille's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
hello everybody

I installed the french zip and the installation running well.

when i use some function I have an error message and I don't know what is it and how to fix it

help will be welcome

here is the error message
Notice: Undefined index: module in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 441

Notice: Undefined index: module in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 484

Notice: Undefined index: id_name in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 488

Notice: Undefined index: module in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 441

Notice: Undefined index: module in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 484

Notice: Undefined index: id_name in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 488

Notice: Undefined index: module in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 441

Notice: Undefined index: module in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 484

Notice: Undefined index: id_name in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 488

Notice: Undefined index: module in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 441

Notice: Undefined index: module in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 484

Notice: Undefined index: id_name in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 488

Notice: Undefined index: module in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 441

Notice: Undefined index: module in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 484

Notice: Undefined index: id_name in C:\xampp\htdocs\demo\SuiteCRM-7.9.4\include\TemplateHandler\TemplateHandler.php on line 488
The administrator has disabled public write access.

error message when using the french translation 1 week 4 days ago #72732

  • holdusback
  • holdusback's Avatar
  • Offline
  • New Member
  • Posts: 15
  • Karma: 0
To add another bug :

With the french translation you cant delete fields in module, you have to login with eng to delete it ...
Last Edit: 1 week 4 days ago by holdusback.
The administrator has disabled public write access.

error message when using the french translation 1 week 4 days ago #72733

  • Livaille
  • Livaille's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
thank you. means you encountered the same problem as me ????
The administrator has disabled public write access.

error message when using the french translation 1 week 4 days ago #72742

  • horus68
  • horus68's Avatar
  • Offline
  • Moderator
  • Posts: 564
  • Thank you received: 138
  • Karma: 30
What is the installed french language version?
And SuiteCRM version?
|| SuiteCRM in your language crowdin.com/project/suitecrmtranslations ||
|| FAQ - Install/Update languages sites.google.com/site/translatingsuitecrm/faq ||
Last Edit: 1 week 4 days ago by horus68.
The administrator has disabled public write access.

error message when using the french translation 1 week 4 days ago #72746

  • Livaille
  • Livaille's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
suite crm version is Version 7.9.4
Sugar Version 6.5.24 (Build 509)

version of translation package downloaded from www.crowdin.com/project/suitecrmtranslations',
version' => '7.10.7.5',

regards
The administrator has disabled public write access.

error message when using the french translation 1 week 4 days ago #72755

  • holdusback
  • holdusback's Avatar
  • Offline
  • New Member
  • Posts: 15
  • Karma: 0
Yes, I have some error that drop randomly, when I quick edit a field, when I try to delete a field, when I had certain type of field etc...

But I dont have the time for now to fix this, I have a lot of customisation to do before.


SuiteCRM-7.10.9
Latest version of the fr translation from here : crowdin.com/project/suitecrmtranslations
Last Edit: 1 week 4 days ago by holdusback.
The administrator has disabled public write access.

error message when using the french translation 1 week 3 days ago #72794

  • blqt
  • blqt's Avatar
  • Offline
  • Senior Member
  • Posts: 77
  • Thank you received: 28
  • Karma: 6
Most of these problems come from escaped quotes (\’) in the translation.
That generates problem for Users, EmailMan, ModuleBuilder, and other modules.
These escaped quotes should be replaced by '
The administrator has disabled public write access.

error message when using the french translation 1 week 3 days ago #72795

  • Livaille
  • Livaille's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
cool thank you for the information
can you tell me how to replace the escape and where
thank you
The administrator has disabled public write access.

error message when using the french translation 1 week 3 days ago #72799

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 7856
  • Thank you received: 1220
  • Karma: 284
Livaille, make sure you download the Language Pack for 7.9.x:

sourceforge.net/projects/suitecrmtransla...x_or_older_versions/

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

error message when using the french translation 1 week 3 days ago #72800

  • Livaille
  • Livaille's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
thank you for the link but it does not explain how to replace / by '
The administrator has disabled public write access.

error message when using the french translation 1 week 2 days ago #72830

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 7856
  • Thank you received: 1220
  • Karma: 284
If you're not using the correct language pack, no wonder you have errors.

It's better to worry about using the correct pack first, and only if that fails, you worry about errors, ok?

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

error message when using the french translation 1 week 2 days ago #72837

  • Livaille
  • Livaille's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
promiss I would do next time
and sorry for wasting your time
The administrator has disabled public write access.

error message when using the french translation 1 week 2 days ago #72839

  • horus68
  • horus68's Avatar
  • Offline
  • Moderator
  • Posts: 564
  • Thank you received: 138
  • Karma: 30
blqt wrote:
Most of these problems come from escaped quotes (\’) in the translation.
That generates problem for Users, EmailMan, ModuleBuilder, and other modules

I must say that using
'
instead of apostrophes in translations (the escaped quotes are automatically placed by Crowdin) its just a dirty hack.
What we need is a list of strings that don't allow escaped quotes so developers would find a way to allow escaped quotes in those files.
There has been some fixes on that issue but not solved in all files!

Issues related:
github.com/salesagility/SuiteCRM/pull/5727
github.com/salesagility/SuiteCRM/pull/4230
github.com/salesagility/SuiteCRM/pull/5568
github.com/salesagility/SuiteCRM/pull/1823
github.com/salesagility/SuiteCRM/commit/...703884ff61d9ca223d67
|| SuiteCRM in your language crowdin.com/project/suitecrmtranslations ||
|| FAQ - Install/Update languages sites.google.com/site/translatingsuitecrm/faq ||
Last Edit: 1 week 2 days ago by horus68.
The administrator has disabled public write access.

error message when using the french translation 1 week 2 days ago #72840

  • blqt
  • blqt's Avatar
  • Offline
  • Senior Member
  • Posts: 77
  • Thank you received: 28
  • Karma: 6
There is also an issue with js language files generation.
Some js files are not correctly generated.
For example:
SUGAR.language.setLanguage('Contacts', );

Using
json_encode($array, JSON_HEX_APOS);

instead of
$json->encode

in include/language/jsLanguage.php should solve that problem
The administrator has disabled public write access.

error message when using the french translation 1 week 2 days ago #72844

  • horus68
  • horus68's Avatar
  • Offline
  • Moderator
  • Posts: 564
  • Thank you received: 138
  • Karma: 30
Can you create an issue in github.com/salesagility/SuiteCRM for the JS problems and include those suggestion so developers can take a look?
|| SuiteCRM in your language crowdin.com/project/suitecrmtranslations ||
|| FAQ - Install/Update languages sites.google.com/site/translatingsuitecrm/faq ||
Last Edit: 1 week 2 days ago by horus68.
The administrator has disabled public write access.
Moderators: horus68
Time to create page: 0.078 seconds
Powered by Kunena Forum