Menu
Welcome, Guest
Username: Password: Remember me

TOPIC: Scheduler URL dropdown menu is blank

Scheduler URL dropdown menu is blank 9 months 2 weeks ago #73756

  • erickimani
  • erickimani's Avatar
  • Offline
  • Junior Member
  • Posts: 27
  • Karma: 1
Hi, I am a newbie on suitecrm and looking for some help iin setting up my first cronjob.

Problem is that when I review the process workflow schedule the job url option is blank an there is some test indicating some kind of error.



Strict Standards: Declaration of SugarFieldTime::save() should be compatible with SugarFieldBase::save(&$bean, $params, $field, $properties, $prefix = '') in /home/readafri/public_html/suitecrm/include/SugarFields/Fields/Time/SugarFieldTime.php on line 95
The administrator has disabled public write access.

Scheduler URL dropdown menu is blank 9 months 2 weeks ago #73762

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10664
  • Thank you received: 1603
  • Karma: 363
Does your SuiteCRM have a version number? :-)

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Scheduler URL dropdown menu is blank 9 months 2 weeks ago #73785

  • erickimani
  • erickimani's Avatar
  • Offline
  • Junior Member
  • Posts: 27
  • Karma: 1
Thanks for your reply.

The version is

Version 7.9.8
Sugar Version 6.5.25 (Build 344)
The administrator has disabled public write access.

Scheduler URL dropdown menu is blank 9 months 2 weeks ago #73801

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10664
  • Thank you received: 1603
  • Karma: 363
Can you update it to the latest 7.9.x? I believe your issue has already been fixed a few versions ago.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Scheduler URL dropdown menu is blank 9 months 2 weeks ago #73810

  • erickimani
  • erickimani's Avatar
  • Offline
  • Junior Member
  • Posts: 27
  • Karma: 1
Ok. Let me try and upgrade and see what happens. Thanks
The administrator has disabled public write access.

Scheduler URL dropdown menu is blank 9 months 2 weeks ago #73884

  • erickimani
  • erickimani's Avatar
  • Offline
  • Junior Member
  • Posts: 27
  • Karma: 1
Hi,

I succeeded in making a clone site, upgraded the suitecrm and now the URLs are showing. Thanks a lot.

Now I want to do a test to see if my scheduler option is working for my workflow task. I created a workflow task for an email to be sent to me if a record had a specific condition. I chose on scheduler only and I assumed it will use the workflow scheduler which is set at every minute. I expected to get many email records by selecting the 'scheduler option only' but I got no email. I have created the cron on the cpanel cron jobs section as directed on the suitecrm.

Can you help please or direct me to a link that can walk me through this process on how to set it up correctly in case I am missing something. Please
The administrator has disabled public write access.

Scheduler URL dropdown menu is blank 9 months 2 weeks ago #73894

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10664
  • Thank you received: 1603
  • Karma: 363
There are several ways to check if your cron jobs are actually running, from Linux. You can also go inside SuiteCRM, Admin / Schedulers, click the Workflow process and see the "Last ran successfully" field: is it recent? Is it in the correct timezone?

Then, if you conclude the Scheduler job is running, you might need to debug your specific Workflow to see if the conditions are well designed, if the options are correct, etc.

See
docs.suitecrm.com/user/advanced-modules/workflow/

the initial section explains in some detail what the options mean, and how they combine.

If you can't get it right please list the exact options you're using (all of them), the exact condition, etc., and I can try to help.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Scheduler URL dropdown menu is blank 9 months 2 weeks ago #73905

  • erickimani
  • erickimani's Avatar
  • Offline
  • Junior Member
  • Posts: 27
  • Karma: 1
Hi, Last successsful run: Never.

Can I give you the login to the clone site you take a quick look please?

I have uploaded somescreen shots of the settings I have used on wetransfer.

wetransfer.com/downloads/1dc5acb178302d3...0181103174001/985287


Thanks for the help
The administrator has disabled public write access.

Scheduler URL dropdown menu is blank 9 months 2 weeks ago #73922

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10664
  • Thank you received: 1603
  • Karma: 363
Sorry, I don't do "logging in" jobs except when payed for it, and right now I'm not taking any offers.

Let's focus only on getting your jobs to run - only when that "never" goes away, you have any chance of getting your Workflow operational.

I suspect that the PHP executable isn't defined in the server's PATH, so it is being found. Your hosting should be able to assist you with this, but you can also try a few things for yourself, if you prefer:

If you have SSH access, type this to get your PHP path:
php -i | grep  '_ ='

Now use this path in your cron command, change the part that says
php -f cron.php

to this:
/usr/bin/php -f cron.php

(or whatever was the path you got)

You can also check your syslog to see if there are any other messages about having trouble running your cron command.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Scheduler URL dropdown menu is blank 9 months 2 weeks ago #73945

  • erickimani
  • erickimani's Avatar
  • Offline
  • Junior Member
  • Posts: 27
  • Karma: 1
Hi,

Thanks for the support you are giving me.

I accessed ssh using putty and typed php -i | grep '_ ='

I got a blank response (see screen shot)

I then decided to use the default option given in the example on cpanel as the path (See attachment)

I now got an error email in my inbox every minute (see attachment) :(

I have put up the screen shots in wetransfer

wetransfer.com/downloads/84755fe98958441...0181105133036/2c3bfc

3 files
The administrator has disabled public write access.

Scheduler URL dropdown menu is blank 9 months 2 weeks ago #73957

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10664
  • Thank you received: 1603
  • Karma: 363
The correct command is
cd /home/africamed/public_html/crm/suitecrm; /usr/local/bin/ea-php71/php -f cron.php > /dev/null 2>&1

or, if that doesn't work,
cd /home/africamed/public_html/crm/suitecrm; /usr/local/bin/ea-php71 -f cron.php > /dev/null 2>&1

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Scheduler URL dropdown menu is blank 9 months 2 weeks ago #73964

  • erickimani
  • erickimani's Avatar
  • Offline
  • Junior Member
  • Posts: 27
  • Karma: 1
Its working! Thanks a million! :)
The administrator has disabled public write access.
Moderators: saschakrause
Time to create page: 0.066 seconds
Powered by Kunena Forum