Menu

Welcome, Guest
Username: Password: Remember me

TOPIC: Upgrading PHP

Upgrading PHP 4 days 19 hours ago #69288

  • nicks
  • nicks's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Hello,

I do apologise if this has been mentioned in the past, I couldn't find any information about this elsewhere. I am using a Linux Centos 7 machine.

I am attempting to upgrade from Version 7.6.6, Sugar Version 6.5.23 (Build 1061) to the latest version.

I have been able to get to Version 7.8.19, Sugar Version 6.5.25 (Build 344) without too many issues but now I am unable to complete the final upgrade to the latest version due to my php being 5.4.9.

I have updated my php to PHP 7.0.30 but Suite still says "Minimum PHP Version 5.4.9. The recommended php version is 7.0.0 or above." Is it possible someone can direct me in the right direction to update the php that Suite uses?
The administrator has disabled public write access.

Upgrading PHP 4 days 19 hours ago #69292

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 6868
  • Thank you received: 1048
  • Karma: 244
You can have more than one version of PHP on the same machine, it looks like SuiteCRM is still using the old one.

You can check this in Admin / Diagnostics, grab phpinfo, download the zip and look inside.
The administrator has disabled public write access.

Upgrading PHP 4 days 18 hours ago #69293

  • nicks
  • nicks's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Thanks, that confirms i'm still using 5.4.9. Sorry if this is obvious but which should I change for Suite to use my updated php?
Configuration File (php.ini) Path
Loaded Configuration File

Thank you
The administrator has disabled public write access.

Upgrading PHP 4 days 18 hours ago #69296

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 6868
  • Thank you received: 1048
  • Karma: 244
Each PHP version will have its own php.ini file.

What you need to do is configure your web server to use the one you want. Google for answers to that (according to which server you're using, I don't know)
The administrator has disabled public write access.
Time to create page: 0.099 seconds
Powered by Kunena Forum