Menu
SuiteCRM dedicated support by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: Changing VAT values results in -NaN,NaN values in invoice

Changing VAT values results in -NaN,NaN values in invoice 4 months 3 days ago #67748

  • parijke
  • parijke's Avatar
  • Offline
  • New Member
  • Posts: 13
  • Karma: 0
I added a key in the VAT list (Hoog, 21%)

When selecting this VAT value in an invoice, the VAT field says -NaN,NaN

It seems that the value is incorrect or somthing. Don't know what to change else

SuiteCRM Versie 7.10.6
Vanilla install with NL language pack
The administrator has disabled public write access.

Changing VAT values results in -NaN,NaN values in invoice 4 months 2 days ago #67756

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 7776
  • Thank you received: 1208
  • Karma: 281
Have you done a Quick Repair and Rebuild? And perhaps some other Admin / Repairs.

Also try it with simple English, no language pack, just to see if it makes a difference.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Changing VAT values results in -NaN,NaN values in invoice 4 months 2 days ago #67757

  • parijke
  • parijke's Avatar
  • Offline
  • New Member
  • Posts: 13
  • Karma: 0
Yes tried a repair en rebuild and tried english. same result
The administrator has disabled public write access.

Changing VAT values results in -NaN,NaN values in invoice 4 months 2 days ago #67760

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 7776
  • Thank you received: 1208
  • Karma: 281
Can you try this in the live demo, to see if the problem is just for your system?

Use this one that allows admin access:

www.softaculous.com/demos/SuiteCRM

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Changing VAT values results in -NaN,NaN values in invoice 4 months 2 days ago #67763

  • parijke
  • parijke's Avatar
  • Offline
  • New Member
  • Posts: 13
  • Karma: 0
Tried to access admin on the softaculous link

Database failure. Please refer to suitecrm.log for details
The administrator has disabled public write access.

Changing VAT values results in -NaN,NaN values in invoice 4 months 2 days ago #67769

  • parijke
  • parijke's Avatar
  • Offline
  • New Member
  • Posts: 13
  • Karma: 0
Same in the demo
The administrator has disabled public write access.

BUG: Changing VAT values results in -NaN,NaN values in invoice 4 months 2 days ago #67770

  • parijke
  • parijke's Avatar
  • Offline
  • New Member
  • Posts: 13
  • Karma: 0
I hand to change this file by hand:

custom/include/language/nl_NL.lang.php

Before:
<?php

$GLOBALS['app_list_strings']['vat_list'] = array(
  '0.0' => '0%',
  'Hoog' => '21%',
);

After:
<?php

$GLOBALS['app_list_strings']['vat_list'] = array(
  '0.0' => '0%',
  '21.0' => '21%',
);


This must be a bug, because when you edit it in the interface you have to choose an alphanumeric value for the key, but the invoice program does not like that and wants a numeric value
Last Edit: 4 months 2 days ago by parijke.
The administrator has disabled public write access.

Changing VAT values results in -NaN,NaN values in invoice 4 months 2 days ago #67786

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 7776
  • Thank you received: 1208
  • Karma: 281
Ok, can you please check Github to see if the issue already exists, and if not, open one? You have all the info for a nice bug report: steps to reproduce, possible fix...

github.com/salesagility/SuiteCRM/issues

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.
Time to create page: 0.060 seconds
Powered by Kunena Forum