Menu
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Scheduled Campaigns not sending.

Scheduled Campaigns not sending. 8 months 2 weeks ago #75082

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10664
  • Thank you received: 1603
  • Karma: 363
Check both your logs for errors.

And please tell me your version of SuiteCRM, and PHP.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Scheduled Campaigns not sending. 8 months 2 weeks ago #75112

  • Asiamah
  • Asiamah's Avatar
  • Offline
  • Senior Member
  • Posts: 50
  • Karma: 0
Suitecrm version is SuiteCRM-7.10.7
php version is 7.2.9


suitecrm log is

Tue Dec 4 12:58:57 2018 [6944][1][FATAL] Slow Query (time:0.1299421787262
DELETE FROM tracker where id = '1711')
Last Edit: 8 months 2 weeks ago by Asiamah.
The administrator has disabled public write access.

Scheduled Campaigns not sending. 8 months 2 weeks ago #75132

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10664
  • Thank you received: 1603
  • Karma: 363
That is just a mention of a slow query, it shouldn't be causing this.

What about the web server log, did you find it?

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Scheduled Campaigns not sending. 8 months 2 weeks ago #75158

  • Asiamah
  • Asiamah's Avatar
  • Offline
  • Senior Member
  • Posts: 50
  • Karma: 0
what am actually seeing is that the code is not running but rather displaying whats in the script......Like the code is displaying itself.
I also saw this error message on the page when i click on a particular email to view.
Fatal error: Uncaught Error: Call to undefined method SugarFieldEmailBody::getVardefValue() in 
C:\xampp\htdocs\CRM\include\SugarFields\Fields\EmailBody\SugarFieldEmailBody.php:61 

Stack trace: 
#0 C:\xampp\htdocs\CRM\include\SugarFields\SugarFieldHandler.php(167): SugarFieldEmailBody->getDetailViewSmarty('fields', Array, Array, NULL) 
#1 C:\xampp\htdocs\CRM\include\Smarty\plugins\function.sugar_field.php(104): SugarFieldHandler::displaySmarty('fields', Array, 'DetailView', Array, NULL) 
#2 C:\xampp\htdocs\CRM\cache\smarty\templates_c\%%1C^1CB^1CB7D149%%tab_panel_content.tpl.php(203): smarty_function_sugar_field(Array, Object(Sugar_Smarty)) 
#3 C:\xampp\htdocs\CRM\include\Smarty\Smarty.class.php(1876): include('C:\\xampp\\htdocs...') 
#4 C:\xampp\htdocs\CRM\cache\smarty\templates_c\%%24^244^24437CF1%%DetailView.tpl.php(286): Smarty->_smarty_include(Array) 
#5 C:\xampp\htdocs\CRM\include\Smarty\Smarty.class.php(1270): include('C:\\xampp\\htdocs...') 
#6 C:\xampp\htdocs\CRM\include\Sugar_Smarty.php(158): Smarty->fetch('themes\\Suite in C:\xampp\htdocs\CRM\include\SugarFields\Fields\EmailBody\SugarFieldEmailBody.php on line 61
Last Edit: 8 months 2 weeks ago by pgr. Reason: add code tags
The administrator has disabled public write access.

Scheduled Campaigns not sending. 8 months 2 weeks ago #75168

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10664
  • Thank you received: 1603
  • Karma: 363
Hi

can you please paste the full contents of your file with this name:

include/SugarFields/Fields/EmailBody/SugarFieldEmailBody.php

you can paste them here:
pastebin.com/
and give us the link. Thanks

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Scheduled Campaigns not sending. 8 months 2 weeks ago #75173

  • Asiamah
  • Asiamah's Avatar
  • Offline
  • Senior Member
  • Posts: 50
  • Karma: 0
Okay, please this is the content of file you are talking about.

Link: pastebin.com/gbp36mNe.
The administrator has disabled public write access.

Scheduled Campaigns not sending. 8 months 2 weeks ago #75179

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10664
  • Thank you received: 1603
  • Karma: 363
Can you please upgrade to 7.10.10? This is fixed in that version.

You can also do only the fix for this particular issue, applying these changes:

github.com/salesagility/SuiteCRM/commit/...8bc5239aa22f16722fb5

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Scheduled Campaigns not sending. 8 months 2 weeks ago #75182

  • amariussi
  • amariussi's Avatar
  • Offline
  • SuiteCRM Is My Life
  • Posts: 1313
  • Thank you received: 291
  • Karma: 68
Usually the php code appears when the webserver is not running or if you are using php code using the php short open tag ("<?") instead of the standard php open tag ("<?php"). To avoid it you should enable short open tags. Otherwise it may be possible that the php code has been written outside the tags or it is output to screen by the script itself, Maybe there are other reasons too but these, to my knowledge are the most common.
The administrator has disabled public write access.

Scheduled Campaigns not sending. 8 months 2 weeks ago #75183

  • Asiamah
  • Asiamah's Avatar
  • Offline
  • Senior Member
  • Posts: 50
  • Karma: 0
ohk thanks .....am going to do that.
The administrator has disabled public write access.

Scheduled Campaigns not sending. 8 months 2 weeks ago #75189

  • Asiamah
  • Asiamah's Avatar
  • Offline
  • Senior Member
  • Posts: 50
  • Karma: 0
Please I have installed the new version but am seeing this in the email list view.


Notice: Undefined index: has_attachment in C:\xampp\htdocs\SuiteCRM\modules\Emails\include\ListView\ListViewDataEmails.php on line 588

Notice: Undefined property: Email::$assigned_user_name in C:\xampp\htdocs\SuiteCRM\modules\Emails\include\ListView\ListViewDataEmailsSearchOnIMap.php on line 380

Notice: Undefined index: has_attachment in C:\xampp\htdocs\SuiteCRM\modules\Emails\include\ListView\ListViewDataEmails.php on line 588

Notice: Undefined property: Email::$assigned_user_name in C:\xampp\htdocs\SuiteCRM\modules\Emails\include\ListView\ListViewDataEmailsSearchOnIMap.php on line 380

Notice: Undefined index: has_attachment in C:\xampp\htdocs\SuiteCRM\modules\Emails\include\ListView\ListViewDataEmails.php on line 588
The administrator has disabled public write access.

Scheduled Campaigns not sending. 8 months 2 weeks ago #75213

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 10664
  • Thank you received: 1603
  • Karma: 363
Typical XAMPP problem, you need to disable display_errors in your php.ini and restart web server.

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.

Scheduled Campaigns not sending. 8 months 2 weeks ago #75218

  • Asiamah
  • Asiamah's Avatar
  • Offline
  • Senior Member
  • Posts: 50
  • Karma: 0
ohk thanx alot..

And the maps module you just keep locations but not able to send locations to clients.
The administrator has disabled public write access.

Scheduled Campaigns not sending. 8 months 1 week ago #75448

  • Asiamah
  • Asiamah's Avatar
  • Offline
  • Senior Member
  • Posts: 50
  • Karma: 0
Please how do run the .bat file when you run your crm files on a remote server.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.041 seconds
Powered by Kunena Forum