Menu
SuiteCRM Pull Request Party hosted by SalesAgility
Welcome, Guest
Username: Password: Remember me

TOPIC: La campaña no envia emails

La campaña no envia emails 1 month 3 weeks ago #79438

  • calatrava
  • calatrava's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
Hola.

Pongo esta consulta aqui por que me han comentado que se necesitaria un desarrollador para esto.

Tengo un hosting compartido en Hostinger. Hay instale suitecrm Version 7.11.2 Sugar Version 6.5.25 (Build 344).

Configure la salida y entrada de los emails, hice las pruebas y me llegan emails.

En las campañas creo todo lo necesario para enviarlas y dice que esta bien.

prntscr.com/n25blo

Debido a que es un hosting compartido en mi cpanel he puesto la ruta del archivo cron.php para que ejecute la tarea dos veces cada hora.

prntscr.com/n25cak

Me da un warning que es el siguiente:

Warning: exec() has been disabled for security reasons in /home/u106252771/domains/timontium.com/public_html/Crm/include/utils.php on line 452

Al parecer este warning se produce en los hostings compartidos, ya que por seguridad desabilitan este "exec()".

He leido que se puede forzar el envio en la cola de envios.

prntscr.com/n25d0f

Pero aunque le doy al boton no sale la campaña.

Alguien puede ayudarme.

Muchas gracias de antemano.
The administrator has disabled public write access.

La campaña no envia emails 1 month 3 weeks ago #79560

  • pgr
  • pgr's Avatar
  • Offline
  • Administrator
  • Posts: 9833
  • Thank you received: 1468
  • Karma: 349
En Admin / Schedulers, busca el nombre del usuario que estas usando para correr el web server. Por debajo de la tabla tienes algo como esto:
In order to run SuiteCRM Schedulers, edit your web server user's crontab file with this command:
sudo crontab -e -u www-data

Ese "www-data" es el nombre de usuario que buscas (puede ser diferente en tu sistema)

Después en esta línea puedes hacer un cambio:

github.com/salesagility/SuiteCRM/blob/ma...clude/utils.php#L452

Pone esto en lugar de lo que está:
$runningUser = 'www-data';

(utiliza el nombre que has descubierto arriba en lugar de www-data)

My SuiteCRM In-depth blog.
Thank you for always stating your SuiteCRM version, checking your logs, reading the Docs, and searching before you ask!
The administrator has disabled public write access.
Moderators: disytel
Time to create page: 0.040 seconds
Powered by Kunena Forum