Menu

SuietASSURED Banner

Save

Save

Welcome, Guest
Username: Password: Remember me

TOPIC: Getting Error in schedulers Cron job

Getting Error in schedulers Cron job 5 days 16 hours ago #57919

  • karthik
  • karthik's Avatar
  • Offline
  • Senior Member
  • Posts: 65
  • Karma: 0
unfortunately i'm getting this error in my errorlog file .

[12-Jan-2018 06:21:03 UTC] PHP Warning: A non-numeric value encountered in /home/arcuscrm/public_html/modules/Schedulers/Scheduler.php on line 409
[12-Jan-2018 06:21:03 UTC] PHP Warning: A non-numeric value encountered in /home/arcuscrm/public_html/modules/Schedulers/Scheduler.php on line 412


Code Part:

for($i=0; $i<60; $i++)
{
if(($currentMin + $i) > 59) {
>>>>>>>>> Line 409
$minName[] = ($i + $currentMin - 60);
} else {
$minName[] = ($i+$currentMin);
}
}
Due to this error Cron jobs are didn't work

I'm Using Version 7.9.7
Sugar Version 6.5.25 (Build 344)

and Wamp server php version 5.6.25.

Anyone guide me how to solve this issue
Suggestion are welcome
Thanks in advance....
The administrator has disabled public write access.

Getting Error in schedulers Cron job 5 days 15 hours ago #57922

  • pgr
  • pgr's Avatar
  • Offline
  • SuiteCRM Is My Life
  • Posts: 3537
  • Thank you received: 570
  • Karma: 135
I read on the Internet one guy who had this error and solved it simply by increasing the memory_limit on his php.ini. What is your current limit? I use 512 MB.

Other than that, maybe you need to look into the data types of those variables. Don't assume they are numeric and can be compared. Use gettype() and check. If necessary, do explicit type conversions before using them in the expression.
The administrator has disabled public write access.

Getting Error in schedulers Cron job 5 days 14 hours ago #57944

  • karthik
  • karthik's Avatar
  • Offline
  • Senior Member
  • Posts: 65
  • Karma: 0
Thanks for your Quick response boss.. After i'm Increasing my memory limit The issue should be happen again...
The administrator has disabled public write access.

Getting Error in schedulers Cron job 3 days 16 hours ago #58048

  • mike201
  • mike201's Avatar
  • Offline
  • Junior Member
  • Posts: 36
  • Thank you received: 5
  • Karma: 1
You may try easycron.com as a cronjob trigger, maybe help to find issue.
The administrator has disabled public write access.

Getting Error in schedulers Cron job 3 days 14 hours ago #58052

  • pgr
  • pgr's Avatar
  • Offline
  • SuiteCRM Is My Life
  • Posts: 3537
  • Thank you received: 570
  • Karma: 135
@mike201 in this case I don't think it will make a difference, since that only changes the way the jobs are triggered, not what errors they give when they run (and his jobs are running)...

It's something weirder.

Anyway, @karthik, I didn't understand your last sentence: is it fine now, or still broken?
The administrator has disabled public write access.
Time to create page: 0.054 seconds
Powered by Kunena Forum